This incident is now resolved. Mail deliverability is now back to normal.
Posted Feb 26, 2026 - 16:46 NZDT
Monitoring
A fix has been implemented and engineers are continuing to monitor. Mail sending functionality has been restored for Outlook.com & Hotmail.com email addresses.
Posted Feb 26, 2026 - 14:56 NZDT
Investigating
Engineers are currently investigating mail issues on CP12 - Excessive email forwarder traffic to Outlook.com & Hotmail.com email addresses have caused an IP block. Engineers are working with Microsoft to get the IP unblocked ASAP.
Posted Feb 26, 2026 - 09:53 NZDT
This incident affected: New Zealand (Auckland) (Web Hosting).